QLOOK ANALYTICS

スポンサーサイト

上記の広告は1ヶ月以上更新のないブログに表示されています。
新しい記事を書く事で広告が消せます。

RGSS3で外部スクリプトをrequireする時の文字コード

RPGツクールVXAce RGSS3のスクリプトを
バージョン管理とかエディタとかの関係でスクリプトを別ファイルで管理してrequireで使いましょう
っていう開発環境を作ったんですが,

いざスクリプトを読み込もうとすると,日本語が入っているスクリプトで以下のエラーがでた.

invalid multibyte char (US-ASCII)

ちゃんとUTF-8にしてるのになんでやねん!!

UTF-8って認識できていないってことは・・・

UTF-8N(BOM付UTF-8)にしたら無事読み込めました.

ちなみにemacsでは
C-x RET f utf-8-with-signature
ね.
関連記事
スポンサーサイト

tag : Ruby RPGツクールVXAce RGSS

プロフィール

gentlawk

Author:gentlawk
「BlueRedZone」を運営
Rubyが大好き
主にゲームプログラミングに取り組む
拍手がつくと地味に喜ぶ

最新記事
最新コメント
最新トラックバック
月別アーカイブ
カテゴリ
検索フォーム
RSSリンクの表示
リンク
Twitter
QRコード
QR
ブロとも申請フォーム

この人とブロともになる

上記広告は1ヶ月以上更新のないブログに表示されています。新しい記事を書くことで広告を消せます。